18 декабря 2016

Wii



Сегодня я познакомлю вас с одной очень популярной в Америке игровой приставкой под названием "Вии". И поделюсь небольшим лайфхаком, как можно неплохо сэкономить играя в Wii на персональном компьютере с помощью эмулятора Dolphin. А так же расскажу какие девайсы нужны для этого.

Wii Remote и аксессуары

Wii - это консоль от хорошо всеми известной японской компании Nintendo. Вещь достаточно культовая, но у нас про нее мало кто знает! Хотя первые продажи стартовали еще в 2006 году, правда не в России. А в 2012 уже вышла новая версия под названием Wii U, более мощная для качественной графики с разрешением 1080p.
Главной изюминкой консоли Wii является специальный беспроводной джойстик Wii Remote, реагирующий на движение и положение в пространстве. Внешне он похож на пульт от телевизора, но начинка и функционал совсем другие.


Держа такой пульт в руке, он заменяет вам меч героя или теннисную ракетку, пистолет или лук, бейсбольную биту или боксерские перчатки. Еще он умеет вибрировать и издавать звуки. Благодаря тактильным ощущениям вы становитесь реальным участником игры и это по настоящему захватывает!


В этом видео наглядно показан принцип работы пульта и описаны компоненты из которых он состоит. Remote содержит 3-х осевой акселерометр ADXL330 от Analog Devices, инфракрасную камеру производства PixArt Imaging, с разрешением 1024x768 пикселей и 100 кадров/сек., динамик, двигатель вибрации, как в сотовых телефонах и  блутуз на чипе Broadcom 2042.
  
Через специальный 6-пиновый разъем к пульту можно подключить дополнительные устройства, такие как, нунчак, классический джойстик или даже гитарный контроллер.

Кроме этого существует множество и других интересных аксессуаров. Такие как, balance board для аэробики, йоги и игр типа сноуборда. Руль Wheel для автосимуляторов, ружье Zapper, объединяющее ремоут с нончакой для игры в шутеры, где игроки могут слышать звуки битвы через динамик wii.  

Приобретение

Теперь перейдем к насущным вопросам, где купить такой римоут? На Aliexpress по запросу "wii remote" вы найдете большое количество предложений, средняя цена около 1000 руб. Только обратите внимание, что бы снизу на нем красовалась надпись "wii motion pluse inside". 

Это означает, что в римоут уже встроен специальный контроллер с дополнительным акселерометром и гироскопом для захвата сложных движений. Там же можно найти и все другие аксессуары по приемлемым ценам. Например, по запросу "wii nunchuk" средняя цена будет 250 руб, zapper - 350 руб, руль - 300 руб. (цены актуальны на момент написания статьи). 

По своему опыту могу сказать, что качество нормальное, от оригинальных вы их ни чем не отличите! Можно смело брать и играть! Но если вдруг вас не устраивает все китайское, можете поискать б/у на ebay, только ценна будет конечно выше.
 
Еще для работы пульта необходима специальная сенсорная планка Wii Sensor Bar с инфракрасными метками.  Она содержит по 5 инфракрасных диода с каждой стороны, что позволяет одновременно играть 4 устройствам.  Правда при отсутствии такой планки вы всегда можете обойтись двумя обычными свечками, но позиционирование будет не таким точным!

Эту планку, кстати, тоже можно заказать на "алике", стоит не дорого, всего 150 руб. (запрос "wii sensor bar"). Единственное что, у нее специальный разъем, который придется отрезать и припаять обычный usb!  Всего два провода, питание 5В.
  
Теперь поговорим о том, как подключить ремоут к компьютеру. Не забываем, что он беспроводной и общается через блутуз. Поэтому позаботимся, что бы у вас был блутуз адаптер.  Я полагаю, что хотя бы один такой у вас уже имеется. Поскольку они поставляются вместе с беспроводными мышками и клавиатурами, а во всех ноутбуках присутствуют де факто.

Далее на примере Windows 8. На панели задач рядом с часами находим значек блутуз, правой кнопкой мыши выбираем "Добавление устройства". 

Откроется окно управления свойствами Bluetooth. Теперь зажмите одновременно кнопки 1 и 2 на ремоуте, на нем начнут мигать лампочки. В это время на экране появится устройство Nintendo RVL-CNT-01. Нужно выполнить его сопряжение.

 
Нажмите кнопку Связать. В следующем окне проверочный код вводить не надо, просто нажмите Далее.

Джойстик провибрирует, на нем загорится первая лампочка, сигнализирующая, что устройство подключено к первому каналу. На экране появится надпись подключено. Все, теперь джойстиком можно пользоваться в эмуляторе.

В дальнейшем, что бы подключать римоуты, ни каких настроек открывать не нужно, просто одновременно зажимаете кнопки 1 и 2, ждете вибрации и  можете играть!

Эмулятор

Как вы уже поняли, что бы играть в Wii совсем не обязательно покупать саму приставку. Достаточно иметь более менее быстрый двухядерный компьютер, на котором надо запустить эмулятор Dolphin.

Этот эмулятор мультиплатформенный, то есть существуют версии, как для Windows, Linux, так и для OSX. Исходный код открытый, поэтому проект активно развивается, обновления разрабатываемых версий выходят чуть ли не каждый день! Подходит не только для игр Wii, но и для GameСube. Игры запускаются в HD качестве, с разрешением 1080p. 

При эмуляции основную роль играет CPU, графической же плате не обязательно быть мощной. Ей достаточно просто уметь выводить изображение с HD разрешением. Справится ли ваш процессор или нет зависит от конкретной игры, но большинство всех стандартных игр пойдут без тормозов, они не требовательне к ресурсам!

Что бы оценить возможности своего процессора можно ознакомиться с результатами тестов приведенными здесь. Таблица отсортирована по времени выполнения теста, сверху самые быстрые. Так же на форуме имеется и сама программа для тестирования, то есть вы можете скачать и запустить ее на своем компьютере и получить свой результат!

У моего i5-2500K @3.3Гц с 8 Гб памяти получился такой результат: total time - 14 мин  55 сек. Это является более чем достаточным показателем для большинства игр!

Переходим к процессу установки. Сначала идем на официальный сайт, там скачиваем последнюю версию dolphin-emu.org. При установке ничего не меняем, просто жмем далее. Запускаем, откроется главное окно программы.

Далее выбираем папку с играми. Откроем меню Опции>Настроить>Вкладка Пути
 

Игры

Игры для эмулятора распространяются в основном в образах iso или wbfs . Большое количество игр с видеообзорами можно найти на следующих сайтах: gamestorrents.com, games.torrentsnack.com, downloadgamestorrents.com, portalroms.com, torfiles.ru.

Безусловно основной причиной бешеной популярности Вии являются сами игры. Ведь в первую очередь Nintendo сделало ставку не на графику и на игровой процесс, поэтому все они интересные и продуманные! В видео ниже я хочу познакомить вас с играми, которые включены в поставку с самой приставкой для демонстрации основных возможностей распознавания движения.


Первая игра, с которой как правило начинается знакомство с Вии, это Wii Sports. Это набор из пяти симуляторов спортивных игр: теннис, бейсбол, гольф, боулинг и бокс. Позднее в 2009 году вышло продолжение Wii Sports Resort, включающая уже 24 игры, где вам и сноуборд, вэйкборд, фризби, фехтование, гребля, стрельба из лука, баскетбол, настольный теннис и др. А в 2013 для Wii U вышел  Wii Sports Club с улучшенной графикой и позволяющий соревноваться с другими участниками онлайн по всему миру.


Второй в списке обязательных игр, должна быть Just Dance! Смысл ее крайне простой, вы смотрите на экран и максимально точно повторяете все движения танцора. Это очень хороший способ научиться танцевать и освоить новые движения!  Эта игра обновляется каждый год с новыми танцевальными хитами.

Просто посмотрите на игровой процесс. Например, как дети танцуют под песню Hey Ya! И вам все станет понятно, насколько это увлекательно и динамично!


Есть еще очень много хороших игр! Напоследок перечислю некоторые из них, которые на мой взгляд заслуживают вашего внимания: Mario Kart, Super Mario Bros, Raving Rabbids4, Rayman Origins, Skyward Sword, Smash Bros, Sonic colours, Super Mario Galaxy 2, Swap Force, Donkey Kong Jet Race, DK Country Returns, FIFA 15.

Приятного время препровождения! Но не забывайте о поговорке делу  -  время, потехе  - час!     

16 ноября 2016

Ошибка при продаже подарочного сертификата УТ 11.2

После обновления на новую версию УТ 11.2 перестали продаваться подарочные сертификаты. При попытке выскакивает сообщение: "не заполнены данные вида сертификата, заполните статью доходов в виде виде сертификата". 


Следуя совету открываем объект справочника ВидыПодарочныхСертификатов и видим, что там нет пункта Статья доходов.

 
Что бы она появилась нужно зайти в НСИ и Администрирование > Настройка Разделов > Финансовый результат и контроллинг и поставить галочку учитывать прочие доходы и расходы


После этого пункт появится!


Но этот реквизит доступен для изменения только при создании новых или уже заполненных объектов. Иначе нужно задавать программно!

&НаСервере
Процедура Команда1НаСервере()
 Выборка = Справочники.ВидыПодарочныхСертификатов.Выбрать();
  Пока Выборка.Следующий() цикл
   ПодСертификат = Выборка.ПолучитьОбъект();
   ПодСертификат.СтатьяДоходов =     ПланыВидовХарактеристик.СтатьиДоходов.НайтиПоНаименованию("Выручка от продаж");
   ПодСертификат.Записать();
  КонецЦикла
КонецПроцедуры


01 ноября 2016

Программная синхронизация узлов РИБ УТ11

На крупных базах процесс синхронизации узлов РИБ занимает достаточно длительное время. База в этот момент подвисает и заставляет себя ждать. Поэтому делаем фоновое выполнение обмена с использованием планировщика заданий Windows.

Реализуется посредством параметра запуска \C
Нужен cmd-файл следующего содержания:
@ECHO OFF
chcp 866
"C:\Program Files (x86)\1cv8\8.3.6.2299\bin\1cv8.exe" enterprise /F e:\1cWorks\ДомСумок /N Администратор /P Boss21 /C"АвтоОбменУзлаРИБ"
  
Далее в МодулеУправлямогоПриложения, в процедуре ПриНачалеРаботыСистемы() нужно проверять параметр запуска и  в зависимости от него выполнять функцию обмена.
 Если СокрЛП(ПараметрЗапуска)="" Тогда   //параметра нет ничего не делаем      
    ИначеЕсли ПараметрЗапуска = "АвтоОбменУзлаРИБ" тогда
        Попытка
            ОбщийМодуль1.ВыболнитьОбменУзлаРИБ();
         Исключение
            Стр="Не удалось выполнить автообмен РИБ ";
            Сообщить(Стр+ОписаниеОшибки());
        КонецПопытки;
        ЗавершитьРаботуСистемы();
    КонецЕсли;
Следует иметь в виду, что этот модуль выполняется на клиенте. Поэтому что бы запустить серверную процедуру, ее следует разместить в отельном общем модуле. Поставить галочку Сервер и Вызов Сервера, после чего можно вызывать эту процедуру обычным способом  ОбщийМодуль1.Процедура()



&НаСервере
Процедура ВыболнитьОбменУзлаРИБ()
    //нужно обновить РИБ по подразделению, который не главный
    // Считаем, что узлов два: главный и не главный
    Выборка = ПланыОбмена.СОтборами.Выбрать();
    Пока выборка.Следующий() цикл
        Если не выборка.ЭтотУзел тогда

            ОбменДаннымиСервер.ВыполнитьОбменДаннымиДляУзлаИнформационнойБазы(,выборка.Ссылка,Истина,Истина);
            Прервать;
        КонецЕсли;
    КонецЦикла;
   
КонецПроцедуры

К слову сказать программный обмен данными для узла осуществляется в общем модуле ОбменДаннымиСервер в функции ВыполнитьОбменДаннымиДляУзлаИнформационнойБазы().

Далее в планировщике заданий создаем новую задачу. Запуск осуществляется с правами системы, тем самым запускается фоновый процесс без интерфейса!

 На вкладке Триггеры задайте расписание, а на вкладке Действия укажите запуск cmd-файла


Теперь в фоне по расписанию будет открываться 1С Предприятие, запускаться внешняя обработка, в которой выполняться обмен данными одного узла РИБ с главным.

Если не нужно срывать процесс, то запускайте cmd-файл с правами обычного пользователя.
В таком случае можно обойтись параметром /Execute и указать файл внешней обработки.
@ECHO OFF
chcp 866
"C:\Program Files (x86)\1cv8\8.3.6.2299\bin\1cv8.exe" enterprise /F e:\ПутьКБазе /N Администратор /P Пароль /Execute e:\Путь\ФайлОбработки.epf
Внешняя обработка, у которой в момент создания будет осуществляться процедура обмена.
&НаСервере
Процедура ПриОткрытии(Отказ)
    ВыболнитьОбменУзлаРИБ(); 
КонецПроцедуры

27 октября 2016

ЗапуститьОбновлениеИнформационнойБазы

Вы создали первоначальный образ РИБ, пробуете его развернуть, но получаете следующую ошибку "В главном узле не обновлен справочник Идентификаторы объектов метаданных" Причина возникновения этого окна в том, что произошел сбой обновления!


Не расстраивайтесь! Прочитайте еще раз внимательно сообщение и следуйте тому, что советуют! А именно нужно запустить 1С Предприятие с параметром запуска ЗапуститьОбновлениеИнформационнойБазы.

Сделать это можно из командной строки с использованием ключа /C

"C:\Program Files (x86)\1cv8\8.3.6.2299\bin\1cv8.exe" enterprise /F e:\1cWorks\ДомСумок /N Администратор /P Boss21 /C"ЗапуститьОбновлениеИнформационнойБазы"
Либо через Конфигуратор, меню Сервис>Параметры, вкладка Запуск 1С Предприятия


Нажать кнопку OK и запустить отладку.  При старте запустится Обновление версии программы.

Теперь осталось повторить создание первоначального образа РИБ на главном узле и развернуть его!

17 октября 2016

Windows не может получить ip адрес от dhcp

Если windows упорно не хочет получать ip от dhcp по lan. А при статических настройках TCP/IP все работает. И другая система подключенная этим проводом работает, значит проблема не в dhcp-сервере!

Первым делом проверьте не блокирует ли вас родной брандмауэр! Панель управления>Брандмауэр Windows> Включение  Отключение.


Отключите его для частных сетей и для общественных.

Если помогло, это означает  отсутствие галочки "обнаружение сети" в меню "Разрешение взаимодействия с приложением или компонентом в брандмауэре".
Поставьте их и можно не отключать фаервол!



 

30 сентября 2016

Как убрать рекламу в uTorrent

Избавляемся от назойливой рекламы в любимом uTorrent 3.4.8 стандартными средствами в три действия!

1) Открываем меню Настройки>Настройки программы


2) Выбираем последний пункт Дополнительно.


3) В поле фильтр вводим следующие параметры:
gui.show_plus_upsell
offers.left_rail_offer_enabled
offers.sponsored_torrent_offer_enabled
И каждому из них присваиваем значение Нет

Нажимаем кнопку OK и любуемся полученным результатом!