19 мая 2017

Сброс парля Windows 7

Предлагается быстрый способ, как создать пользователя с правами Администратора, если таковыми вы не обладаете.

1) При включении зажимаете F8, выбираете Восстановление системы, откроется окно параметров Восстановления системы.
 
2) Выбираете Командную строку. В ней пишите 
regedit.exe
3) Откроется редактор реестра. Выберите раздел HLM и в меню файл выберите Загрузить куст.

4) Указываем файл Windows\System32\Config\system. Дайте имя куста, например 555.
5) Открываем ветку реестра HLM\555\Setup. 
6) Там редактируем два параметра: 
  • CmdLine, вводим значение cmd.exe 
  • SetupType меняем значение 0 на 2
7) Презагружаемся. Откроется командная строка с параметрами системы.

8) Далее добавляем нового администатора
net user Имя Пароль /add
net localgroup Администраторы Имя /add
net localgroup Пользователи Имя /delete
На этом все, можно входить в систему!



HKEY_LOCAL_MACHINE\888\SetupИсточник: https://www.windxp.com.ru/win7/articles45.htm
HKEY_LOCAL_MACHINE\888\SetupИсточник: https://www.windxp.com.ru/win7/articles45.htm
HKEY_LOCAL_MACHINE\888\SetupИсточник: https://www.windxp.com.ru/win7/articles45.htm
.юHKEY_LOCAL_MACHINEИсточник: https://www.windxp.com.ru/win7/articles45.htm
HKEY_LOCAL_MACHINEИсточник: https://www.windxp.com.ru/win7/articles45.htm
Выделите раздел HKEY_LOCAL_MACHINE, как показано на рисунке ниже. Затем из меню Файл выберите пункт Загрузить кустИсточник: https://www.windxp.com.ru/win7/articles45.htm
Выделите раздел HKEY_LOCAL_MACHINE, как показано на рисунке ниже. Затем из меню Файл выберите пункт Загрузить кустИсточник: https://www.windxp.com.ru/win7/articles45.htm
 

13 апреля 2017

Полезные windows команды

Узнать производителя и модель материнской платы
>wmic baseboard get manufacturer
>wmic baseboard get product
Отобразить пользователей, вошедших  в систему и узнать, как долго они простаивают
>quser
Проверка и восстановление целостности системных файлов.
sfc /scannow 

07 марта 2017

Несколько RDP сессий к Windows 7, 8,10

По умолчанию в не серверных версиях windows можно выполнить только одно подключение к удаленному рабочему столу, при этом работа текущего пользователя обязательно блокируется.

Исправляем это недоразумение.

Обязательно сохраним оригинальный файл termsrv.dll. Запустим командную строку от Администратора и выполним
copy c:\Windows\System32\termsrv.dll termsrv.dll_old
Затем смотрим вашу версию. Правый клик на файле c:\Windows\System32\termsrv.dll и выберем свойства.


Скачиваем измененный файл соответствующий вашей версии

Windows 8.1 (64bit)
v6.3.9600.16384
от v6.3.9600.16384 до v6.3.9600.17095
от v6.3.9600.17095 до v6.3.9600.17415

Windows 10 x64

v10.0.10240.16384 
до v10.0.10586.0 

Если хочется все исправить своими руками, то копируем свой файл  termsrv.dll из папки c:\Windows\System32\ на рабочий стол. Открываете его любым hex редактором, например этим бесплатным HxD. И заменяете байты в указанной строчке.
В первой колонке значение, которое должно быть, во второй оригинальное.

Windows 7 SP1 64bit:
173C0: B8 8B
173C1: 00 87
173C2: 01 38
173C3: 00 06
173C5: 90 00
173C6: 89 39
173C8: 38 3C
173CC: 90 0F
173CD: 90 84
173CE: 90 EB
173CF: 90 C2
173D0: 90 00
173D1: 90 00
176FA: 00 01
5AD7E: EB 74
Для Windows 8.1 (64bit) заменяем целиком строку
 
в v6.3.9600.16384
строчку
8B 81 38 06 00 00 39 81 3C 06 00 00 0F 84 1B 70 00 00
на
B8 00 01 00 00 89 81 38 06 00 00 90 90 90 90 90 90 90

в 6.3.9600.16384 to 6.3.9600.17095
строчку
39 81 3C 06 00 00 0F 84 9E 31 05 00
на
B8 00 01 00 00 89 81 38 06 00 00 90

6.3.9600.17095 to 6.3.9600.17415
строчку
39 81 3C 06 00 00 0F 84 D3 1E 02 00
на
B8 00 01 00 00 89 81 38 06 00 00 90
 Воспользуемся инструментом замены с типом шестнадцатеричные значения



После замены сохраняете изменения.

Если испытываете трудности с правами доступа, то открываете свойства, вкладку безопасность, кнопка дополнительно. И меняете владельца на себя. Применяете. После этого сможете менять разрешения для групп и пользователей.



Далее останавливаете службу удаленного рабочего стола


Заменяем файл termsrv.dll на скаченный или измененный.

Еще нужно изменить значение ключа в реестре HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\fSingleSessionPerUser на 0!

И снова запускаем службу!

Подключаемся и радуемся!

02 февраля 2017

1С галочки для табличного поля

Вы разрабатываете некую форму, на ней у вас есть табличное поле привязанное к списку какого-либо справочника. И вы хотите реализовать механизм отметки нужных строк галочками.

Делается очень просто! Для этого вы добавляете новую колонку, через контекстное меню.


Называете ее "Отметка". Выбираете элемент управления Флажок.


Затем создаете реквизит ОтмеченныеСтроки с типом СписокЗначений, в нем будем хранить какие строки отметили.

У табличного поля задействуем два события, первое ПриВыводеСтроки, сробатывает всякий раз, когда система выводит строку табличного поля и ПриИзмененииФлажка, когда пользователь изменяет состояние флажка в колонках табличного поля.


 В этих процедурах нужно написать следующее
Процедура ТабличноеПоле1ПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
  ОформлениеСтроки.Ячейки.Отметка.ОтображатьФлажок = Истина;
  Если ОтмеченныеСтроки.НайтиПоЗначению(ДанныеСтроки.Ссылка) =   Неопределено Тогда
    ОформлениеСтроки.Ячейки.Отметка.Флажок = Ложь;
  Иначе
    ОформлениеСтроки.Ячейки.Отметка.Флажок = Истина;
  КонецЕсли;
КонецПроцедуры
Здесь мы отображаем флажок в ячейке и выводим его значение согласно списку значений.

Процедура ТабличноеПоле2ПриИзмененииФлажка(Элемент, Колонка)
   Если Колонка.Имя = "Отметка" Тогда
     НайденныйЭлемент =  ОтмеченныеСтроки.НайтиПоЗначению(Элемент.ТекущаяСтрока);
      Если НайденныйЭлемент = Неопределено Тогда
        ОтмеченныеПользователи.Добавить(Элемент.ТекущаяСтрока);
      Иначе
        ОтмеченныеПользователи.Удалить(НайденныйЭлемент);
      КонецЕсли;
   КонецЕсли;
КонецПроцедуры
Обрабатываем только колонку Отметка. Если в списке значений уже есть строка, по которой кликнули, то ее удаляем, это означает снятие галочки. И наоборот, если текущей строки нет - добавляем.

В дополнение было бы весьма удобно реализовать механизмы отметить и снять все галочки! Располагаете на форме командную панель, на ней две кнопки. По нажатию на одной выполняете процедуру:
Процедура КоманднаяПанельДействиеОтметитьВсе(Кнопка)
   Выборка = Справочники.Пользователи.Выбрать();
   Пока Выборка.Следующий() цикл
     ОтмеченныеСтроки.Добавить(Выборка.Ссылка);
   КонецЦикла;
   ЭтаФорма.Обновить();
КонецПроцедуры
Здесь в цикле перебираются все записи (в данном случае это справочник пользователи, поэтому перебираем выборку) и добавляются с список значений ОтмеченныеСтроки. После выполняется перерисовка формы.

Для снятия всех галочек достаточно выполнить Очистку списка значений ОтмеченныеСтроки.
Процедура КоманднаяПанельДействиеСнятьВсе(Кнопка)
    ОтмеченныеПользователи.Очистить();
    ЭтаФорма.Обновить();
КонецПроцедуры
В итоге у вас получится вот такая табличная часть с дополнительной колонкой Отметка, где выбираются нужные строки, они будут попадать в список значений ОтмеченныеСтроки. И в дальнейшем, перебирая ОтмеченныеСтроки сможете производить с ними какие либо действия! Над таблицей есть две кнопки, установить все галочки и снять!

Успехов, терпения и удачных решений!

25 января 2017

1С Поле выбора

Если вы с толкнулись с проблемой, что поле ввода, а точнее поле выбора с галочкой РежимВыбораИзСписка не отображает данные привязанного реквизита. То скорее всего вы неправильно заполняете список значений. Есть одна особенность при работе с этим элементом!


Посмотрите на свой код, если вы создаете новый список значений, а потом присваиваете его свойству СписокВыбора.

СписокЗн = Новый СписокЗначений;
СписокЗн.Добавить(0, "Безналичный");
СписокЗн.Добавить(1, "Наличный");
ЭлементыФормы.ВидДоговораНалБезнал.СписокВыбора = СписокЗн;
То имейте в виду, что это не верно! Надо работать непосредственно со списком значений, который находится в свойстве СписокВыбора!
СписокЗн = ЭлементыФормы.ВидДоговораНалБезнал.СписокВыбора;
СписокЗн.Добавить(0, "Безналичный");
СписокЗн.Добавить(1, "Наличный");
Либо использовать функцию ЗагрузитьЗначения()
СписокЗн = Новый СписокЗначений;
СписокЗн.Добавить(0, "Безналичный");
СписокЗн.Добавить(1, "Наличный");
ЭлементыФормы.ВидДоговораНалБезнал.СписокВыбора.ЗагрузитьЗначения(СписокЗн.Выгрузить() )

18 января 2017

Windows's life hacks

1) Меняем язык ввода  при входе в систему по умолчанию для ввода пароля.
Открываем ветку реестра: 
HKEY_USERS\.DEFAULT\Keyboard Layout\Preload
там есть два ключа
00000409 - английская
00000419 - русская
порядок следования определяет какой будет первым.






18 декабря 2016

Wii



Сегодня я познакомлю вас с одной очень популярной в Америке игровой приставкой под названием "Вии". И поделюсь небольшим лайфхаком, как можно неплохо сэкономить играя в Wii на персональном компьютере с помощью эмулятора Dolphin. А так же расскажу какие девайсы нужны для этого.

Wii Remote и аксессуары

Wii - это консоль от хорошо всеми известной японской компании Nintendo. Вещь достаточно культовая, но у нас про нее мало кто знает! Хотя первые продажи стартовали еще в 2006 году, правда не в России. А в 2012 уже вышла новая версия под названием Wii U, более мощная для качественной графики с разрешением 1080p.
Главной изюминкой консоли Wii является специальный беспроводной джойстик Wii Remote, реагирующий на движение и положение в пространстве. Внешне он похож на пульт от телевизора, но начинка и функционал совсем другие.


Держа такой пульт в руке, он заменяет вам меч героя или теннисную ракетку, пистолет или лук, бейсбольную биту или боксерские перчатки. Еще он умеет вибрировать и издавать звуки. Благодаря тактильным ощущениям вы становитесь реальным участником игры и это по настоящему захватывает!


В этом видео наглядно показан принцип работы пульта и описаны компоненты из которых он состоит. Remote содержит 3-х осевой акселерометр ADXL330 от Analog Devices, инфракрасную камеру производства PixArt Imaging, с разрешением 1024x768 пикселей и 100 кадров/сек., динамик, двигатель вибрации, как в сотовых телефонах и  блутуз на чипе Broadcom 2042.
  
Через специальный 6-пиновый разъем к пульту можно подключить дополнительные устройства, такие как, нунчак, классический джойстик или даже гитарный контроллер.

Кроме этого существует множество и других интересных аксессуаров. Такие как, balance board для аэробики, йоги и игр типа сноуборда. Руль Wheel для автосимуляторов, ружье Zapper, объединяющее ремоут с нончакой для игры в шутеры, где игроки могут слышать звуки битвы через динамик wii.  

Приобретение

Теперь перейдем к насущным вопросам, где купить такой римоут? На Aliexpress по запросу "wii remote" вы найдете большое количество предложений, средняя цена около 1000 руб. Только обратите внимание, что бы снизу на нем красовалась надпись "wii motion pluse inside". 

Это означает, что в римоут уже встроен специальный контроллер с дополнительным акселерометром и гироскопом для захвата сложных движений. Там же можно найти и все другие аксессуары по приемлемым ценам. Например, по запросу "wii nunchuk" средняя цена будет 250 руб, zapper - 350 руб, руль - 300 руб. (цены актуальны на момент написания статьи). 

По своему опыту могу сказать, что качество нормальное, от оригинальных вы их ни чем не отличите! Можно смело брать и играть! Но если вдруг вас не устраивает все китайское, можете поискать б/у на ebay, только ценна будет конечно выше.
 
Еще для работы пульта необходима специальная сенсорная планка Wii Sensor Bar с инфракрасными метками.  Она содержит по 5 инфракрасных диода с каждой стороны, что позволяет одновременно играть 4 устройствам.  Правда при отсутствии такой планки вы всегда можете обойтись двумя обычными свечками, но позиционирование будет не таким точным!

Эту планку, кстати, тоже можно заказать на "алике", стоит не дорого, всего 150 руб. (запрос "wii sensor bar"). Единственное что, у нее специальный разъем, который придется отрезать и припаять обычный usb!  Всего два провода, питание 5В.
  
Теперь поговорим о том, как подключить ремоут к компьютеру. Не забываем, что он беспроводной и общается через блутуз. Поэтому позаботимся, что бы у вас был блутуз адаптер.  Я полагаю, что хотя бы один такой у вас уже имеется. Поскольку они поставляются вместе с беспроводными мышками и клавиатурами, а во всех ноутбуках присутствуют де факто.

Далее на примере Windows 8. На панели задач рядом с часами находим значек блутуз, правой кнопкой мыши выбираем "Добавление устройства". 

Откроется окно управления свойствами Bluetooth. Теперь зажмите одновременно кнопки 1 и 2 на ремоуте, на нем начнут мигать лампочки. В это время на экране появится устройство Nintendo RVL-CNT-01. Нужно выполнить его сопряжение.

 
Нажмите кнопку Связать. В следующем окне проверочный код вводить не надо, просто нажмите Далее.

Джойстик провибрирует, на нем загорится первая лампочка, сигнализирующая, что устройство подключено к первому каналу. На экране появится надпись подключено. Все, теперь джойстиком можно пользоваться в эмуляторе.

В дальнейшем, что бы подключать римоуты, ни каких настроек открывать не нужно, просто одновременно зажимаете кнопки 1 и 2, ждете вибрации и  можете играть!

Эмулятор

Как вы уже поняли, что бы играть в Wii совсем не обязательно покупать саму приставку. Достаточно иметь более менее быстрый двухядерный компьютер, на котором надо запустить эмулятор Dolphin.

Этот эмулятор мультиплатформенный, то есть существуют версии, как для Windows, Linux, так и для OSX. Исходный код открытый, поэтому проект активно развивается, обновления разрабатываемых версий выходят чуть ли не каждый день! Подходит не только для игр Wii, но и для GameСube. Игры запускаются в HD качестве, с разрешением 1080p. 

При эмуляции основную роль играет CPU, графической же плате не обязательно быть мощной. Ей достаточно просто уметь выводить изображение с HD разрешением. Справится ли ваш процессор или нет зависит от конкретной игры, но большинство всех стандартных игр пойдут без тормозов, они не требовательне к ресурсам!

Что бы оценить возможности своего процессора можно ознакомиться с результатами тестов приведенными здесь. Таблица отсортирована по времени выполнения теста, сверху самые быстрые. Так же на форуме имеется и сама программа для тестирования, то есть вы можете скачать и запустить ее на своем компьютере и получить свой результат!

У моего i5-2500K @3.3Гц с 8 Гб памяти получился такой результат: total time - 14 мин  55 сек. Это является более чем достаточным показателем для большинства игр!

Переходим к процессу установки. Сначала идем на официальный сайт, там скачиваем последнюю версию dolphin-emu.org. При установке ничего не меняем, просто жмем далее. Запускаем, откроется главное окно программы.

Далее выбираем папку с играми. Откроем меню Опции>Настроить>Вкладка Пути
 

Игры

Игры для эмулятора распространяются в основном в образах iso или wbfs . Большое количество игр с видеообзорами можно найти на следующих сайтах: gamestorrents.com, games.torrentsnack.com, downloadgamestorrents.com, portalroms.com, torfiles.ru.

Безусловно основной причиной бешеной популярности Вии являются сами игры. Ведь в первую очередь Nintendo сделало ставку не на графику и на игровой процесс, поэтому все они интересные и продуманные! В видео ниже я хочу познакомить вас с играми, которые включены в поставку с самой приставкой для демонстрации основных возможностей распознавания движения.


Первая игра, с которой как правило начинается знакомство с Вии, это Wii Sports. Это набор из пяти симуляторов спортивных игр: теннис, бейсбол, гольф, боулинг и бокс. Позднее в 2009 году вышло продолжение Wii Sports Resort, включающая уже 24 игры, где вам и сноуборд, вэйкборд, фризби, фехтование, гребля, стрельба из лука, баскетбол, настольный теннис и др. А в 2013 для Wii U вышел  Wii Sports Club с улучшенной графикой и позволяющий соревноваться с другими участниками онлайн по всему миру.


Второй в списке обязательных игр, должна быть Just Dance! Смысл ее крайне простой, вы смотрите на экран и максимально точно повторяете все движения танцора. Это очень хороший способ научиться танцевать и освоить новые движения!  Эта игра обновляется каждый год с новыми танцевальными хитами.

Просто посмотрите на игровой процесс. Например, как дети танцуют под песню Hey Ya! И вам все станет понятно, насколько это увлекательно и динамично!


Есть еще очень много хороших игр! Напоследок перечислю некоторые из них, которые на мой взгляд заслуживают вашего внимания: Mario Kart, Super Mario Bros, Raving Rabbids4, Rayman Origins, Skyward Sword, Smash Bros, Sonic colours, Super Mario Galaxy 2, Swap Force, Donkey Kong Jet Race, DK Country Returns, FIFA 15.

Приятного время препровождения! Но не забывайте о поговорке делу  -  время, потехе  - час!