16 ноября 2016

Ошибка при продаже подарочного сертификата УТ 11.2

После обновления на новую версию УТ 11.2 перестали продаваться подарочные сертификаты. При попытке выскакивает сообщение: "не заполнены данные вида сертификата, заполните статью доходов в виде виде сертификата". 


Следуя совету открываем объект справочника ВидыПодарочныхСертификатов и видим, что там нет пункта Статья доходов.

 
Что бы она появилась нужно зайти в НСИ и Администрирование > Настройка Разделов > Финансовый результат и контроллинг и поставить галочку учитывать прочие доходы и расходы


После этого пункт появится!


Но этот реквизит доступен для изменения только при создании новых или уже заполненных объектов. Иначе нужно задавать программно!

&НаСервере
Процедура Команда1НаСервере()
 Выборка = Справочники.ВидыПодарочныхСертификатов.Выбрать();
  Пока Выборка.Следующий() цикл
   ПодСертификат = Выборка.ПолучитьОбъект();
   ПодСертификат.СтатьяДоходов =     ПланыВидовХарактеристик.СтатьиДоходов.НайтиПоНаименованию("Выручка от продаж");
   ПодСертификат.Записать();
  КонецЦикла
КонецПроцедуры


01 ноября 2016

Программная синхронизация узлов РИБ УТ11

На крупных базах процесс синхронизации узлов РИБ занимает достаточно длительное время. База в этот момент подвисает и заставляет себя ждать. Поэтому делаем фоновое выполнение обмена с использованием планировщика заданий Windows.

Реализуется посредством параметра запуска \C
Нужен cmd-файл следующего содержания:
@ECHO OFF
chcp 866
"C:\Program Files (x86)\1cv8\8.3.6.2299\bin\1cv8.exe" enterprise /F e:\1cWorks\ДомСумок /N Администратор /P Boss21 /C"АвтоОбменУзлаРИБ"
  
Далее в МодулеУправлямогоПриложения, в процедуре ПриНачалеРаботыСистемы() нужно проверять параметр запуска и  в зависимости от него выполнять функцию обмена.
 Если СокрЛП(ПараметрЗапуска)="" Тогда   //параметра нет ничего не делаем      
    ИначеЕсли ПараметрЗапуска = "АвтоОбменУзлаРИБ" тогда
        Попытка
            ОбщийМодуль1.ВыболнитьОбменУзлаРИБ();
         Исключение
            Стр="Не удалось выполнить автообмен РИБ ";
            Сообщить(Стр+ОписаниеОшибки());
        КонецПопытки;
        ЗавершитьРаботуСистемы();
    КонецЕсли;
Следует иметь в виду, что этот модуль выполняется на клиенте. Поэтому что бы запустить серверную процедуру, ее следует разместить в отельном общем модуле. Поставить галочку Сервер и Вызов Сервера, после чего можно вызывать эту процедуру обычным способом  ОбщийМодуль1.Процедура()



&НаСервере
Процедура ВыболнитьОбменУзлаРИБ()
    //нужно обновить РИБ по подразделению, который не главный
    // Считаем, что узлов два: главный и не главный
    Выборка = ПланыОбмена.СОтборами.Выбрать();
    Пока выборка.Следующий() цикл
        Если не выборка.ЭтотУзел тогда

            ОбменДаннымиСервер.ВыполнитьОбменДаннымиДляУзлаИнформационнойБазы(,выборка.Ссылка,Истина,Истина);
            Прервать;
        КонецЕсли;
    КонецЦикла;
   
КонецПроцедуры

К слову сказать программный обмен данными для узла осуществляется в общем модуле ОбменДаннымиСервер в функции ВыполнитьОбменДаннымиДляУзлаИнформационнойБазы().

Далее в планировщике заданий создаем новую задачу. Запуск осуществляется с правами системы, тем самым запускается фоновый процесс без интерфейса!

 На вкладке Триггеры задайте расписание, а на вкладке Действия укажите запуск cmd-файла


Теперь в фоне по расписанию будет открываться 1С Предприятие, запускаться внешняя обработка, в которой выполняться обмен данными одного узла РИБ с главным.

Если не нужно срывать процесс, то запускайте cmd-файл с правами обычного пользователя.
В таком случае можно обойтись параметром /Execute и указать файл внешней обработки.
@ECHO OFF
chcp 866
"C:\Program Files (x86)\1cv8\8.3.6.2299\bin\1cv8.exe" enterprise /F e:\ПутьКБазе /N Администратор /P Пароль /Execute e:\Путь\ФайлОбработки.epf
Внешняя обработка, у которой в момент создания будет осуществляться процедура обмена.
&НаСервере
Процедура ПриОткрытии(Отказ)
    ВыболнитьОбменУзлаРИБ(); 
КонецПроцедуры

27 октября 2016

ЗапуститьОбновлениеИнформационнойБазы

Вы создали первоначальный образ РИБ, пробуете его развернуть, но получаете следующую ошибку "В главном узле не обновлен справочник Идентификаторы объектов метаданных" Причина возникновения этого окна в том, что произошел сбой обновления!


Не расстраивайтесь! Прочитайте еще раз внимательно сообщение и следуйте тому, что советуют! А именно нужно запустить 1С Предприятие с параметром запуска ЗапуститьОбновлениеИнформационнойБазы.

Сделать это можно из командной строки с использованием ключа /C

"C:\Program Files (x86)\1cv8\8.3.6.2299\bin\1cv8.exe" enterprise /F e:\1cWorks\ДомСумок /N Администратор /P Boss21 /C"ЗапуститьОбновлениеИнформационнойБазы"
Либо через Конфигуратор, меню Сервис>Параметры, вкладка Запуск 1С Предприятия


Нажать кнопку OK и запустить отладку.  При старте запустится Обновление версии программы.

Теперь осталось повторить создание первоначального образа РИБ на главном узле и развернуть его!

17 октября 2016

Windows не может получить ip адрес от dhcp

Если windows упорно не хочет получать ip от dhcp по lan. А при статических настройках TCP/IP все работает. И другая система подключенная этим проводом работает, значит проблема не в dhcp-сервере!

Первым делом проверьте не блокирует ли вас родной брандмауэр! Панель управления>Брандмауэр Windows> Включение  Отключение.


Отключите его для частных сетей и для общественных.

Если помогло, это означает  отсутствие галочки "обнаружение сети" в меню "Разрешение взаимодействия с приложением или компонентом в брандмауэре".
Поставьте их и можно не отключать фаервол!



 

30 сентября 2016

Как убрать рекламу в uTorrent

Избавляемся от назойливой рекламы в любимом uTorrent 3.4.8 стандартными средствами в три действия!

1) Открываем меню Настройки>Настройки программы


2) Выбираем последний пункт Дополнительно.


3) В поле фильтр вводим следующие параметры:
gui.show_plus_upsell
offers.left_rail_offer_enabled
offers.sponsored_torrent_offer_enabled
И каждому из них присваиваем значение Нет

Нажимаем кнопку OK и любуемся полученным результатом!
 

06 октября 2015

Ограничение доступа к RDP с помощью политик

Как вы прекрасно знаете доступ к RDP по умолчанию имеют группы Администраторы и Пользователи удаленного рабочего стола. Очень хотелось бы отключить такую возможность для Администратора. 

Поэтому возникает резонный вопрос, как запретить определенным пользователям доступ по RDP

Делается это очень легко через оснастку групповой политики. 
Идем меню Пуск > Выполнить (Win+R) и вводим  gpedit.msc. Откроется Редактор локальной групповой политики. Так же его можно открыть через консоль управления mmc

Открываем ветку Конфигурация компьютера > Конфигурация Windows > Параметры безопасности > Локальные политики > Назначение прав пользователя. Там находим политику "Разрешить вход в систему через службу удаленных рабочих столов".


И удаляем из списка группу Администраторы, нажимаем Применить.


Теперь только Пользователи удаленного рабочего стола могут подключаться по RDP. Если нужно явно запретить конкретного пользователя, есть политики  "Запретить вход в систему через службу удаленных рабочих столов" или "Отказать в доступе к этому компьютеру из сети".

03 октября 2015

Как сделать аудиокнигу M4B

Добрый день. В интернете есть множество аудиокниг в формате M4B. И все обладатели айподов и айфонов знают насколько удобно прослушивать такие аудиокниги на своих устройствах!

Но что делать, если вдруг вы не нашли, что искали и вам захотелось создать книжку собственноручно из отдельных mp3 файлов? Тогда эта заметка для вас! В ней описывается, как создавать аудиокниги в формате M4B для ваших любимых iOS-девайсов.

Немного о насущном. Что такое M4B и за счет чего достигается удобство использования?

Во-первых, M4B это ни что иное, как используемое компанией Apple свое расширение для контейнера MP4 с упакованным в него ACC-потоком и механизмом закладок. Это позволяет продолжить прослушивание с того самого места, где вы остановились. Во-вторых, благодаря встроенному оглавлению, вы сразу можете переключаться на нужную главу. Ну и в-третьих, алгоритм ACC обладает лучшим качеством кодирования по сравнению с MP3 и это дает лучшее звучание при меньшем объеме файла.

На компьютере формат M4B легко воспроизводится всеми современными плеерами, например, VLC, Classic Media Player, а так же встроенным Winsows Media Player и др. Перемещение по главам осуществляется через меню Navigation>Chapters или Воспроизведение>Главы.

Но удобнее всего, конечно, использовать программы Apple. В iTunes на момент прослушивания аудиокниги в главном меню появляется раздел Главы.



В QuickTime Player'e еще удобней, прямо на интерфейсе есть специальный переключатель. 

 

Теперь ближе к делу, как их создавать.

Первое, что приходит на ум, можно прямо из iTunes переконвертировать файл MP3 в ACC, а полученный *.m4a переименовать в *.m4b. Но при таком методе не будет оглавления. А что бы объединить несколько mp3 в один придется использовать какую-нибудь дополнительную программу редактор, например SoundForge.

Но есть способ лучше! Для Windows существует бесплатное приложение Chapter and Verse. Скачать его можно с официального сайта, по ссылке. Программа позволяет объединять несколько аудиофайлов любого формата в один выходной файл аудиокниги. Для каждого файла создаются ссылки в оглавлении. И они автоматически конвертируются в ACC, используя iTuтes. Поэтому перед установкой убедитесь, что у вас установлены QuickTime и iTunes, без них програмка не запустится!

Перед использованием желательно настроить параметры конвертирования. Для этого запускаем программу Chapter and Verse, переходим в меню Tools>Options, вкладка Convertion Options. В разделе "...Output File Directory" должна стоять галочка "...the same directory as input" files, что означает сохранять сконвертированные файлы там же, где исходные.

Ниже в разделе Default ACC Encoder Settings выберите "High Quality (128 kbps)", это оптимально даже для прослушивания музыки. Если по каким то причинам вас это не устраивает, выберите Custom и настройте вручную. По окончании нажмите Save

 

Теперь приступаем непосредственно к созданию аудиокниги.

Порядок действий крайне простой.  

1) На вкладке Input Files кнопкой Add Files выбираете нужные файлы. Затем, если это не ACC вам предложат их переконвертировать, нажимайте Yes - Convert.

  
2) Переходите на вкладку Chapters. Здесь в разделе "Chapter Naming - Prefixes" можно настроить, как формировать оглавление, это могут быть: <Filenames> - названия файлов, <Metadata Title> - название трека из ID3 тэгов или <Chapter> - пользовательский шаблоны с счетчиком. И конечно можно вручную редактировать название каждой главы.

 

3) На вкладке Metadata можно задать картинку для аудиокниги. Если нужно, то для каждой главы отдельно, либо для всех одну, тогда достаточно только для первого файла.


Теперь осталось только нажать Build Audiobook и получить заветный M4B файл.

Наслаждайтесь прослушиванием и пусть будет больше хороших аудиокнижек!